. Написать программу, которая выводит массив в обратном порядке. Написать три функции...

0 голосов
74 просмотров

. Написать программу, которая выводит массив в обратном порядке. Написать три функции (заполнение массива, вывод данных, вывода в обратном порядке).
Сделайте по с++ пожалуйстааааа очень прошу, у меня ровно час!!!


Информатика (21 баллов) | 74 просмотров
Дан 1 ответ
0 голосов

Программа должна считать массив, поменять порядок его элементов, затем вывести результат (просто вывести элементы массива в обратном порядке – недостаточно!)

Входные данные
Сначала задано число N — количество элементов в массиве (1N35). Далее через пробел записаны N чисел — элементы массива. Массив состоит из целых чисел.

Выходные данные
Необходимо вывести массив, полученный после перестановки элементов.

Примеры
входные данные
6
4 5 3 4 2 3

выходные данные
3 2 4 3 5 4

(74 баллов)
0

мне надо сам код((

0

примени эту программу
uses crt; // сдвиг массива вправо на К элементов
const n=10;
k=2;
var x: array [1..n] of integer;
y,i,j: integer;
begin
for i:=1 to n do x[i]:=2*i;
for j:=1 to k do begin
y:=x[n];
for i:=n downto 2 do x[i]:=x[i-1];
x[1]:=y;
end;
for i:=1 to n do write(x[i]:4);
readln;
end.
0/1

0

скинь библиотеку плиз))