Помогите написать программу(С++) Даны два числа. Найти среднее арифметическое кубов этих...

0 голосов
229 просмотров

Помогите написать программу(С++)
Даны два числа. Найти среднее арифметическое кубов этих чисел и среднее геометрическое модулей этих чисел.
Исходные данные разместить на двух строках.
Выдать на печать информацию в виде:
а) пропустить три строки
б) в центре листа напечатать ответ в виде:
СРЕДНЕЕ АРИФМЕТИЧЕСКОЕ КУБОВ ЧИСЕЛ X и Y:
(X^3+Y^3)/2=.....
СРЕДНЕЕ ГЕОМЕТРИЧЕСКОЕ МОДУЛЕЙ ЧИСЕЛ:
(Abs(X)*abs(Y))/2=.....
***********************
в) ИСХОДНЫЕ ДАННЫЕ
X=.....
Y=.....
***********************


Информатика | 229 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

#include
#include
#include
using namespace std;

int main() {
setlocale(LC_ALL, "Russian");
int x, y;
cout << "x=";<br> cin >> x;
cout << "y=";<br> cin >> y;
cout << "\n\n\n"<br> << "СРЕДНЕЕ АРИФМЕТИЧЕСКОЕ КУБОВ ЧИСЕЛ X и Y:\n"<br> << "(X^3+Y^3)/2=" <br> << ( ( pow(x,3) + pow(y,3) ) / 2 )<br> << '\n'<br> << "СРЕДНЕЕ ГЕОМЕТРИЧЕСКОЕ МОДУЛЕЙ ЧИСЕЛ:\n"<br> << "(abs(X)*abs(Y))/2="<br> << ( ( abs(x) * abs(y) ) / 2 )<br> << "\n********************\n"<br> << "ИСХОДНЫЕ ДАННЫЕ\n"<br> << "X=" << x << '\n'<br> << "Y=" << y << '\n'<br> << "********************";<br>}

(7.2k баллов)
0

Вообще, то, среднее геометрическое двух чисел - это корень квадратный из произведения этих чисел.

0

В описании формула указана иначе, так что я её повторил.