Составьте программу вычисления функции y=sinx2^n используйте подпрограмму,функцию для ее...

0 голосов
71 просмотров

Составьте программу вычисления функции y=sinx2^n используйте подпрограмму,функцию для ее вычисления


Информатика (17 баллов) | 71 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

Var x,y:real; n:integer;
function f(x:real;n:integer):real;
var i,st:integer;
begin
st:=1;
for i:=1 to n do st:=st*2;
f:=sin(x)*st;
end;
begin
writeln('x, n:');
readln(x,n);
y:=f(x,n);
writeln('x = ',x,' y = ',y);
end.

Пример:
x, n:
2 5
x = 2 y = 29.0975176584218

(194k баллов)
0

Спасибо большое)

0 голосов

Program sinus;
var x,y:real;
begin
writeln('введите число');
readln(x);
y:=sin(x)*2*2;
writeln(y);
end.

(14 баллов)