Очень нужна помощь. Нужно составить программу по массивам(в паскале). 19 вариант.

0 голосов
63 просмотров

Очень нужна помощь.
Нужно составить программу по массивам(в паскале). 19 вариант.


image

Информатика (181 баллов) | 63 просмотров
Дан 1 ответ
0 голосов
var 
  k,l,n,i: integer;
  a: array[1..100] of boolean;
  b: char;
begin
  k:=0; l:=0;
  write ('Введите длину массива: ');
  readln (n);
  writeln ('Введите массив:');
  for i:=1 to n do begin
      readln (b);
      case b of
          'F','f': a[i]:=false;
          'T','t': a[i]:=true;
          else begin writeln ('неверные данные '); exit; end;
      end;
      if a[i]=true 
          then k:=k+1
          else 
              if (k>0) and (k>l) 
                  then begin l:=k; k:=0 end
                  else k:=0;
  end;
  if (k>0) and (k>l) then l:=k;     
  for i:=1 to n do begin
      write (a[i]:7);
      if i mod 8 =0 then writeln;
  end;    
  writeln;
  writeln ('Длина = ',l)
end.
----------------результат:-----------------
Введите длину массива: 16
Введите массив:
t
t
t
t
t
t
f
t
t
t
t
t
f
t
t
t
   True   True   True   True   True   True  False   True
   True   True   True   True  False   True   True   True

Длина = 6

(3.5k баллов)