Напишите программу, которая вычисляет следующее значение. По теореме Пифагора, в...

0 голосов
35 просмотров

Напишите программу, которая вычисляет следующее значение. По теореме Пифагора, в прямоугольном треугольнике соотношение сторон C2=A2+B2. Если A=3, B=2, каково значение C? В PascalABC.


Информатика (19 баллов) | 35 просмотров
Дан 1 ответ
0 голосов

Формула c^2=a^2+c^2 

Программа 
var a, b, S: real;
begin
 writeln('Введите a');
 readln(a);
 writeln('Введите b');
 readln(b);
 S:=Sqrt(a*a+b*b);
 writeln('Извлеченный корень из числа "c" : ', S:1:1);
end.

Если a=3, b=2, тогда корень 3.6

(8.0k баллов)
0

читайте внимательнее условие

0

Я написал все правильно

0

program Teorema_P;
var A, B, C: real;
begin
writeln ('Введите значение первого катета:');
readln (A);
writeln ('Введите значение второго катета:');
readln (B);
C:=sqrt(A*A + B*B);
writeln ('Катет А = ', A, ', катет В = ', B, ', гипотенуза С = ', C:5:3);
end. значит это неправильно?

0

и где A2,B2,C2?