Напишите программу,которая вычисляет сумму : а)первых n натуральных чисел; б)квадратов...

0 голосов
150 просмотров

Напишите программу,которая вычисляет сумму :
а)первых n натуральных чисел;
б)квадратов первых n натуральных чисел;
в)всех чётных чисел в диапазоне от 1 до n;
г)всех двузначный чисел.


Информатика (12 баллов) | 150 просмотров
Дан 1 ответ
0 голосов

Т.к. язык программирования не указан, сделаю на свой вкус, т.е. C++. При копировании кода из IDE на сайт автоматически удаляется перенос строки. Будет прикреплен скриншот того, как должен выглядеть код

#include #include #include
void main(){setlocale(LC_ALL, "RUSSIAN");int i, n, an;an = 0;printf("\n Введите n ->");scanf_s("%d", &n);for (i = 1; i <= n; i++) an = an+i;printf("\n Сумма первых n натуральных чисел равна: %d", an);an = 0;for (i = 1; i <= n; i++) an = an + i*i;printf("\n Сумма квадратов первых n натуральных чисел равна: %d", an);an = 0;for (i = 1; i <= n; i++) if (i % 2 == 0)an = an + i;printf("\n Сумма всех четных чисел в диапозоне от 1 до n: %d", an);an = 0;for (i = 10; i <= 99; i++) an = an + i;printf("\n Сумма всех двухзначных чисел равна: %d \n", an);system("pause");}<br>


image
(1.5k баллов)