60 баллов! Написать программу в паскаль. см внутри

0 голосов
18 просмотров

60 баллов! Написать программу в паскаль. см внутри


image

Информатика (1.8k баллов) | 18 просмотров
Дано ответов: 2
0 голосов
Правильный ответ
// PascalABC.NET 3.2, сборка 1356 от 04.12.2016
// Внимание! Если программа не работает, обновите версию!

begin
  var m:=ReadSeqReal('Введите 5 чисел:',5).Average;
  Writeln('Ср. арифм. элементов равно ',m)
end.

Пример
Введите 5 чисел: 14 13.2 15.1 16 9.64
Ср. арифм. элементов равно 13.588
(150k баллов)
0 голосов

Var
  a: array[1..5] of integer;
  sa: real;
  i: byte;
begin
  writeln ('Введите числа: ');
  sa:=0;
  for i:=1 to 5 do begin
    read (a[i]);
    sa:=sa+a[i];
  end;
  sa:=sa/(i);
  writeln ('Среднее арифметическое = ',sa);
end.

--------------------------------------
Введите числа: 
2 3 4 5 6
Среднее арифметическое = 4

(3.5k баллов)