Написать программу ** С#, которая будет менять в заданном в программе массиве целых чисел...

0 голосов
36 просмотров

Написать программу на С#, которая будет менять в заданном в программе массиве целых чисел все элементы, которые равны указанному значению, на противоположное значению по знаку.


Информатика (37 баллов) | 36 просмотров
Дан 1 ответ
0 голосов
Правильный ответ
using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.Threading.Tasks;
namespace zamenaZnakaVmassive
{
class Program
{
static void Main(string[] args)
{
int[] mas = new int[10];
Random r = new Random();
Console.WriteLine("Исходный массив: ");
for (int i = 0; i {
mas[i] = r.Next(1, 10);
Console.Write(mas[i] + " ");
}
Console.WriteLine();
Console.WriteLine("Введите значение");
int x = int.Parse(Console.ReadLine());
Console.WriteLine("Измененный массив: ");
for (int i =0; i < mas.Length; i++)
{
if (mas[i] == x) mas[i] = mas[i] * (-1);
Console.Write(mas[i] + " ");
}
Console.ReadKey();
{
}
}
}
}

(991 баллов)