В городе BykhovTown требуются программисты. Для того, чтобы вакансии с наибольшей...

0 голосов
50 просмотров

В городе BykhovTown требуются программисты. Для того, чтобы вакансии с наибольшей заработной платой не остались не востребованными, мэр города составил таблицу, содержащую данные о номере фирмы и заработной плате. Так как данные в таблице не упорядочены найти самую высокую зарплату не так уж и просто. Напишите программу, которая выберет для вас лучшую вакансию.
Входные данные:
В первой строке входного файла записано единственное число N, 1<=N<=300000, определяющее количество вакансий. <br> Во второй строке, через пробел записаны зарплаты фирм (числа от 1 до 65000).
Выходные данные:
В единственную строку выходного файла необходимо вывести наибольшую заработную плату в списке.
Входные данные:
5
23 45 12 45000 3200
Выходные данные:
45000


Информатика (106 баллов) | 50 просмотров
Дан 1 ответ
0 голосов

Var i,k, max, N: integer;
a: array[1..300000] of integer;
Begin
read(N);
for i:=1 to N do
read(a[i]);
max := a[1];
for i :=2 toN do
if a[i]>max thenbegin
max:= a[i];
end;
write(max);
End.

(98 баллов)