Помогите написать программу на языке Паскаль. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. Кто правильно напишет поставлю лучшее решение!!!
Var n,a,i,k:integer; begin write('n = '); readln(n); k:=0; writeln('Вводите числа:'); for i:=1 to n do begin readln(a); if a mod 4 = 0 then k:=k+1; end; writeln('k = ',k); end. Пример: n = 5 Вводите числа: 15 24 73 48 94 k = 2
Спасибо, теперь верно!
Var a: array [1..100] of integer; chis,i: integer; begin readln(chis); for i:=1 to chis do readln(a[i]); write('Числа кратные 4:'); for i:=1 to chis do if (a[i] mod 4 = 0) then write(a[i], ' '); end.
Просили найти количество чисел, кратных 4.
достаточно приписать еще одну переменную и делать инкреминг
Так припишите.