В классе 20 учеников писали диктант по русскому языку. Напишите программу и начертите к...

0 голосов
74 просмотров

В классе 20 учеников писали диктант по русскому языку. Напишите программу и начертите к ней блок-схему, подсчитывающую количество двоек, троек, четверок и пятерок за диктант. Просто срочно, даю 99 баллов за программу и блок-схему.


Информатика (1.9k баллов) | 74 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Блок-схема - в прилагаемом файле. Программа:
const n=20;
var a:array[1..20] of integer;
i,k2,k3,k4,k5:integer;
begin
Randomize;
writeln('Оценки:');
for i:=1 to n do begin
 a[i]:=random(4)+2;
 write(a[i],' ');
 end;
writeln;
k2:=0;k3:=0;k4:=0;k5:=0;
for i:=1 to n do
 case a[i] of
  2: k2:=k2+1;
  3: k3:=k3+1;
  4: k4:=k4+1;
  5: k5:=k5+1;
 end;
writeln('Двоек: ',k2);
writeln('Троек: ',k3);
writeln('Четверок: ',k4);
writeln('Пятёрок: ',k5);
end.

Пример:
Оценки:
3 5 3 2 5 3 2 5 3 4 4 5 2 3 3 4 4 2 2 5 
Двоек: 5
Троек: 6
Четверок: 4
Пятёрок: 5


image
(194k баллов)