Помогите составить программу в Pascal. Дана строка символов, состоящая из слов,...

0 голосов
30 просмотров

Помогите составить программу в Pascal. Дана строка символов, состоящая из слов, разделенных пробелами. Найти количество слов с пятью символами.


Информатика (17 баллов) | 30 просмотров
Дан 1 ответ
0 голосов

Var y:string;   
c,kolvo:int64;
begin
readln(y);
for var i:=1 to Length(y) do begin
if y[i]<>' ' then c+=1 else c:=0;if c=5 then begin if Length(y)-i>=1 then begin if y[i+1]=' ' then kolvo+=1; end else kolvo+=1; end;end;
writeln(kolvo);
end.

(4.0k баллов)