В классе 20 учеников писали диктант по русскому языку.Напишите программу,подсчитывающую...

0 голосов
326 просмотров

В классе 20 учеников писали диктант по русскому языку.Напишите программу,подсчитывающую количество двоек,троек,четвёрок и пятёрок,полученных за диктант. Ребят,пожалуйста,очень срочно!!!кто хорошо знает-пишите,не из Интернета !!!


Информатика (74 баллов) | 326 просмотров
Дан 1 ответ
0 голосов

Если с клавиатуры вводить оценки, то так
var
a,b,c,d:integer;
begin
a:=0; b:=0; c:=0;
for i:=1 to 20 do 
begin
readln(d);
if d=2 then inc(a) else
if d=3 then inc(b) else
if d=4 then inc(c);
end;
write(' dvoek - ', a, 'troek - ', b, 'chetverok - ', c);
readln;
end.

(34 баллов)