40 баллов! Написать программу в паскаль!

0 голосов
24 просмотров

40 баллов! Написать программу в паскаль!


image

Информатика (1.8k баллов) | 24 просмотров
Дано ответов: 2
0 голосов
Правильный ответ
// PascalABC.NET 3.2, сборка 1363 от 17.12.2016
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ReadArrReal('Вводите массив:',6);
  Writeln('П=',a.Where(x->x<0).Aggregate(1.0,(x,y)->x*y))
end.

Пример
Вводите массив: 5 -8 3 -4.5 7 -1.15
П=-41.4
(150k баллов)
0 голосов

Const n=6;
var a:array[1..n] of integer;
i,p:integer;
begin
writeln('Введите 6 элементов массива:');
for i:=1 to n do read(a[i]);
p:=1;
for i:=1 to n do
 if a[i]<0 then p:=p*a[i];<br>writeln('p = ',p);
end.

Пример:
Введите 6 элементов массива:
5 -8 3 -4 7 -1
p = -32

(194k баллов)
0

Большое спасибо! А можете, пожалуйста, написать еще три программы: https://znanija.com/task/21899336? 85 баллов