Составить программу в PascalABC За сколько дней может похудеть спортсмен со 100 до 80 кг,...

0 голосов
60 просмотров

Составить программу в PascalABC
За сколько дней может похудеть спортсмен со 100 до 80 кг, если в день он может сбрасывать 1% своего веса от нормы предыдущего дня?


Информатика (21 баллов) | 60 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var m:real; k:integer;
begin
m:=100; k:=0;
while m>80 do
 begin
 k:=k+1;
 m:=m*0.99;
 end;
writeln('k = ',k);
end.

Результат:
k = 23

(194k баллов)