Помогите, пожалуйста! Нужно написать программу для АВС паскаль. Программа должна...

0 голосов
48 просмотров

Помогите, пожалуйста! Нужно написать программу для АВС паскаль. Программа должна переводить обыкновенные числа в двоичную систему счисления. Заранее большое спасибо! 87 баллов!!


Информатика (1.7k баллов) | 48 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

Var n,m:integer;
s:string;
begin
write('n = ');
readln(n);
m:=n;
s:='';
while m>0 do
 begin
 if m mod 2=0
  then s:='0'+s else s:='1'+s;
 m:=m div 2;
 end;
writeln(s);
end.

Пример:
n = 115
1110011

(194k баллов)
0 голосов

Var
  a: integer;

function p(x: integer): string;
var
  s: string;
begin
  s := '';
  while x > 0 do
  begin
    s := chr(ord('0') + x mod 2) + s;
    x := x div 2;
  end;
  p := s;
end;

begin
  readln(a);
  writeln(p(a));
end.

(577 баллов)