Составьте программу, Которая формирует массив из десяти случайных чисел от -45 до 45 и...

0 голосов
39 просмотров

Составьте программу, Которая формирует массив из десяти случайных чисел от -45 до 45 и меняет местами значение первого и последнего элементов


Информатика (19 баллов) | 39 просмотров
0

тебе выводить изначальный и получившийся массивы?

Дано ответов: 2
0 голосов
Правильный ответ
// PascalABC.NET 3.2, сборка 1362 от 14.12.2016
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(10,-45,45); a.Println;
  Swap(a[0],a[9]); a.Println
end.

Пример
32 -1 21 17 13 11 -7 14 -7 4
4 -1 21 17 13 11 -7 14 -7 32
(150k баллов)
0 голосов

Type mas= Array [1..10] of integer;
var i,M:integer;
a:mas;
begin
randomize;
for i:=1 to 10
do begin
A[i]:=random (-45,45);
write(A[i],' ');
end;
writeln();
A[1]:=M
A[i]:=A[10]; 
A[10]:=M;
for i:=1 to 10
do write(A[i],' ');
end.

(1.2k баллов)