Написать программу которая заполняет масив из -10;20 и находит сумму кратных 5

0 голосов
62 просмотров

Написать программу которая заполняет масив из -10;20 и находит сумму кратных 5


Информатика (39 баллов) | 62 просмотров
0

Она рандомными числами заполняет?

0

да

Дан 1 ответ
0 голосов

Var  i,summa,x,y:integer;  arr: array [-10..20] of integer;begin  randomize;  x:=0;  for i:=-10 to 20 do    begin    arr[i]:=random(100);    if arr[i] mod 5=0 then      x:=x+arr[i];    end; writeln(x);  end.  

(92 баллов)
0

var
i,summa,x,y:integer;
arr: array [-10..20] of integer;
begin
randomize;
x:=0;
for i:=-10 to 20 do
begin
arr[i]:=random(100);
if arr[i] mod 5=0 then
x:=x+arr[i];
end;
writeln(x);
end.