ПОМОГИТЕ СРОЧНО ПО ИНФЕ!!(9КЛАСС) PASCAL ABC а)составьте программу, которая заполняет...

0 голосов
43 просмотров

ПОМОГИТЕ СРОЧНО ПО ИНФЕ!!(9КЛАСС) PASCAL ABC
а)составьте программу, которая заполняет массив a[1..10] случайными целыми числами в диапазоне от 1 до 10 и находит сумму эелементов с чётными и количиство элементов с нечётными значениями.
б)составьте программу, которая заполняет массив a[1..8] случайными целыми числами в диапазоне от 1 до 10 и находит сумму элементов с нечётными и количиство элементов с чётными значениями.
в)Составьте программу, которая заполняет массив a[1..10] случайными целыми числами в диапазоне от 1 до 10 и находит количество элементов с чётными значениями.
г)Составьте программу, которая заполняет массив b[1..8] случайными целыми числами в диапазоне от 1 до 10 и находит количество элементов с нечётными значениями.


Информатика (28 баллов) | 43 просмотров
Дан 1 ответ
0 голосов

На самом деле я пишу на С++, но я думаю ты легко переведёшь это на паскаль.
В а случае мы просто проходимся по циклу, а потом проверяем на корректность. Т.е:
Пускай у нас есть массив arr размером 10.
Тогда:
for (int i = 0; i < 10; ++i) {arr[i]=rand(1,10);}
После этого включаем счётчик c
int c=0;
Ну и проходимся опять.
for (int i = 0; i < 10; ++i) {
if(i%2==0 && arr[i]%2==1) {c += arr[i];}
}

По такому принципу работают и другие случаи, просто меняется проверка в цикле а также что мы прибавляем к с (1 или arr[i]):
б) i%2==1 && arr[i]%2==0; c+= arr[i];
в) arr[i]%2==0; c++;
г) arr[i]%2==1; c++;

Если полностью программа, то это примерно так (для случая в):
int main() {
int arr[10]; int c = 0;
for (int i = 0; i < 10; ++i) arr[i] = rand(1,10);
for (int i = 0; i < 10; ++i) {
if(arr[i] % 2 == 0) c++;
}
cout << c;<br>}

(1.2k баллов)
0

Блин можешь на Pascal я ваще не шарю

0

И надо по инфе на Pascal

0

Ну в паскале я не шарю вообще. Я тебе целиком решение сказал, язык не важен. Ваще это материал класса 6 так-то... Ну лан.

0

Можешь подсказать как это перевести в паскал?

0

Ну % - это mod. arr a[100] - это вроде var arr:array of integer[1..10]