PASCALНаписать программу для нахождения принадлежности точки с координатами x,y...

0 голосов
107 просмотров
PASCAL
Написать программу для нахождения принадлежности точки с координатами x,y заштрихованной области

image

Информатика (43 баллов) | 107 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

Var x, y: real;
begin readln(x, y);
          if (y>=0) and (y<=sinx) and (x>=1-y) and (x<=Pi) then<br>          writeln('принадлежит')
          else writeln('не принадлежит');
readln;
end.

(2.1k баллов)
0 голосов

Const pi=3.14;var x,y,y1,y2:real;beginreadln(x,y);y1:=-x+1;y2:= sin(x);if (y1>=0) and (x>=1) thenif (y2<=1) and (x<=pi) then writeln('Принадлежит')else writeln('Не принадлежит')else writeln('Не принадлежит');end.<br>

(1.4k баллов)
0

const pi=3.14;
var x,y:real;
begin
readln(x,y);
if (x>1) and (xif (y>0) and (y<1) then writeln(' Принадлежит')<br>else writeln('Не принадлежит')
else writeln('Не принадлежит');
end.

0

Но тут синусоида, с ней надо

0

Изменил решение. Взгляни.

0

Только не x+1, а 1+x. А так, спасибо)

0

Только там -x+1

0

Воу, незаметно было, извиняюсь. -x+1 и x+1 все равно одинаковые графики, так что,