Даны 3 числа(а,в,с). Составьте программу, которая меняет местами max и min элементы.Не...

0 голосов
59 просмотров

Даны 3 числа(а,в,с). Составьте программу, которая меняет местами max и min элементы.Не массив.


Информатика (20 баллов) | 59 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

Var a,b,c,d:integer;
begin
writeln('a, b, c:');
readln(a,b,c);
if (a>b)and(ac)and(a then begin d:=b; b:=c; c:=d; end
 else if (b>a)and(bc)and(b       then begin d:=a; a:=c; c:=d; end
       else begin d:=a; a:=b; b:=d; end;
writeln('a = ',a,' b = ',b,' c = ',c);
end.

Пример:
a, b, c:
8 5 2
a = 2 b = 5 c = 8

(194k баллов)
0 голосов

Var
  a,b,c:integer;
  max,min:integer;
begin
  readln(a,b,c);
  if ((a>=b)and(a>=c)and(b<=c))or((b>=a)and(b>=c)and(a<=c)) then swap(a,b)<br>  else
    if ((a>=b)and(a>=c)and(c<=b))or((c>=b)and(c>=a)and(a<=b)) then swap(a,c)<br>    else
      if ((b>=a)and(b>=c)and(c<=a))or((c>=b)and(c>=a)and(b<=a)) then swap(b,c);  writeln(a,' ',b,' ',c);<br>end.

(3.4k баллов)
0

Простите но она не работает

0

какая у вас версия паскаля?