Составьте программу, которая выводит ** экран нечётные числа от 1 до 50 в порядке...

0 голосов
51 просмотров

Составьте программу, которая выводит на экран нечётные числа от 1 до 50 в порядке убывания.(Цикл "While").


Информатика (29 баллов) | 51 просмотров
0

Язык программирования?

Дан 1 ответ
0 голосов

Pascal:

program decrement;
var
  i: integer;
begin
  i := 50;
  while i >= 1 do
    begin
      if i mod 2 = 1 then
        writeln(i, ' ');
      i := i - 1;
    end;
end.

---

C++:

#include

int main() {
    int i = 50;
    while (i >= 1) {
        if (i % 2 == 1)
            std::cout << i << ' ';<br>        i--;
    }
    return 0;
}

(7.2k баллов)