Написать программу, формирующую линейный массив A[1..40] по следющему правилу: первые...

0 голосов
43 просмотров

Написать программу, формирующую линейный массив A[1..40] по следющему правилу: первые двадцать элементов массива равняются 1, остальные двадцать - 0.
pascal


Информатика (36 баллов) | 43 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Const N=40;var A: array[1..N] of integer;i:integer;beginfor i:=1 to 20 do A[i]:=1;for i:=21 to N doA[i]:=0;for i:=1 to N dowrite(A[i]:3);end.

(3.4k баллов)
0

const N=40;
var A: array[1..N] of integer;
i:integer;
begin
for i:=1 to 20 do
A[i]:=1;
for i:=21 to N do
A[i]:=0;
for i:=1 to N do
write(A[i]:3);
end.