Помогите пожалуйста написать программу и блок схему. Вот задание: даны две точки: А(x1;...

0 голосов
79 просмотров

Помогите пожалуйста написать программу и блок схему. Вот задание: даны две точки: А(x1; y1) и B(x2; y2) нужно составить программу определяющую, какая из точек находится ближе к началу координат.


Информатика (12 баллов) | 79 просмотров
Дан 1 ответ
0 голосов

Var x1,y1,x2,y2,d1,d2:real;
begin
  write ('X1 = ');
  readln (x1);
  write ('Y1 = ');
  readln (y1);
  write ('X2 = ');
  readln (x2);
  write ('Y2 = ');
  readln (y2);
  d1:=sqrt(sqr(x1)+sqr(y1));
  d2:=sqrt(sqr(x2)+sqr(y2));
  if d1<>d2 then write ('К началу координат ближе ');
   if d1>d2 then writeln ('вторая точка') else
    if d2>d1 then writeln ('первая точка') else
      writeln ('Обе точки равноудалены друг от друга');
end.

(2.8k баллов)