Напишите программу в паскале, плиз. В этой задаче необходимо посчитать суммарную площадь...

0 голосов
35 просмотров

Напишите программу в паскале, плиз.
В этой задаче необходимо посчитать суммарную площадь прямоугольников двух видов. Известно, что количество всех прямоугольников равно удвоенному значению положительной целочисленной ширины прямоугольников первого вида, и прямоугольников обоих видов — поровну.
Формат входных данных
В единственной строке записаны четыре целых положительных числа h1,w1,h2,w2 (высота и ширина для первого и второго видов прямоугольников соответственно). Все числа лежат в диапазоне от 0 до 106 включительно.
Формат результата
Выведите единственное число – ответ на задачу.
Примеры
Входные данные 1 2 3 4
Результат работы 28



Информатика (203 баллов) | 35 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Введем обозначение. Все, относящееся к прямоугольникам первого вида будет иметь индекс 1, ворого вида - индекс 2.
Пусть имеется n₁ и n₂ прямоугольников. По условию n₁+n₂ = w₁ и n₁=n₂, откуда n₁=w₁ и n₂=w₁
Площади: S₁=w₁×h₁, S₂=w₂×h₂
Общая площадь S = n₁×w₁×h₁ + n₁×w₂×h₂ = w₁×(w₁×h₁ + w₂×h₂)

// PascalABC.NET 3.2, сборка 1345 от 24.11.2016
// Внимание! Если программа не работает, обновите её версию!
begin
  var h1,w1,h2,w2:real;
  Read(h1,w1,h2,w2);
  Writeln(w1*(w1*h1+w2*h2))
end.

Пример
1 2 3 4
28

(150k баллов)