PascalABC Нужно составить программу для вывода ближайшего степени 2-ки

0 голосов
32 просмотров

PascalABC
Нужно составить программу для вывода ближайшего степени 2-ки


Информатика (49 баллов) | 32 просмотров
Дан 1 ответ
0 голосов
Правильный ответ
// PascalABC.NET 3.2, сборка 1356 от 04.12.2016
// Внимание! Если программа не работает, обновите версию!

begin
  var s:=ReadInteger('Введите натуральное число:');
  var p:=Round(log2(s));
  Writeln('Два в степени ',p,' = ',power(2,p))
end.

Пример
Введите натуральное число: 4093532
Два в степени 22 = 4194304
(150k баллов)