Программа ** Паскале. Составить программу превода натурального числа N из 10 системы...

0 голосов
46 просмотров

Программа на Паскале. Составить программу превода натурального числа N из 10 системы счисления в 8 систему счисления через рекурсию. Что число натуральное, проверять не надо. Если что то не понятно, спрашивайте.


Информатика (108 баллов) | 46 просмотров
Дан 1 ответ
0 голосов

Begin
 if n > 1 then  
decTo5(n div 5);
 write(n mod 5);
end;  
var  n: integer;  
begin
  write('n = ');
  readLn(n);  
if (n > 0) then  
  decTo5(n)  
else  
 writeLn('Error, n must > 0!');  
writeLn;
end.
Извини меня если не правильно. Вроде так.

(286 баллов)
0

Что означает 3 строчка?

0

рекурсия, Ты хоть знаешь что это?

0

Да

0

Но не понимаю, что значит decto5

0

Тебе в паскале нужно ?

0

Я просто думал что в сс также

0

Нет паскаль именно

0

прости)

0

давай так, по любому другому предмету и вопросу пиши мне я тебе отвечу)

0

У меня ток инфа страдает (