Составить программу, которая обеспечит ввод 15 чисел и определит сколько из них...

0 голосов
77 просмотров

Составить программу, которая обеспечит ввод 15 чисел и определит сколько из них отрицательных, которые кратны 3.


Информатика (172 баллов) | 77 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var a,i,k:integer;
begin
k:=0;
writeln('Введите 15 целых чисел:');
for i:=1 to 15 do
 begin
 readln(a);
 if (a<0)and(a mod 3 = 0) then k:=k+1;<br> end;
writeln('k = ',k);
end.

Пример:
Введите 15 целых чисел:
75
-65
15
-68
28
-42
80
-76
51
-32
18
-16
-45
70
-65
k = 2

(194k баллов)
0

Самое забавное, что у меня почти такое же получилось. Спасибо.