Составьте программу, которая позволяет заменить в строке слово мама ** слово папа

0 голосов
73 просмотров

Составьте программу, которая позволяет заменить в строке слово мама на слово папа


Информатика (24 баллов) | 73 просмотров
Дан 1 ответ
0 голосов

Var //Объявляем переменные
i:integer;
s:string;
begin // Начало работы блока
readln(s); // В переменную S записываем введенную строку
i := Pos('мама', s);  // В переменную i записываем количество символов до данного слова
if i > 0 then //Если количество символов больше нуля тогда
 begin  
Delete(s, i, 4);  // Удаляем из веденной строки (Переменная S), слово мама, содержащие 4 символа 
Insert('папа', s, i);  // Заменяем словом Папа
end; //Конец
writeln(s); //Выводим на экран полученный текст
end.

(904 баллов)