Помогите нужно составить программу,которая формирует массив с 16 случайных целых чисел от...

0 голосов
27 просмотров

Помогите нужно составить программу,которая формирует массив с 16 случайных целых чисел от -20 до 20 и: находит элементы с нулевыми значениями


Информатика (67 баллов) | 27 просмотров
0

Т.е. находит если нули в этом массиве ? если так то как выводить их ?( ну число нулей в массиве или что ) и какой массив (одномерный или двумерный)?

Дано ответов: 2
0 голосов

Не понял смысл задачи. 
Написал, вывод номера элементов равных 0.


image
(231 баллов)
0 голосов

#include #include
int main(void){    int mas[16]; //массив со случайными числами    int i; //счетчик
    //заполнение массива случайными числами    for(i=0; i<16; i++)    mas[i] = -20+rand()%20;    printf("ishodny massiv");    for(i=0;i<16;i++)        printf("%d,",mas[i]);    printf("\n");<br>    printf("nomera elementov massiva ravnih nulu");    for(i=0;i<16;i++)    if (mas[i]==0) printf("%d",i+1);<br>return 0;}

(444 баллов)