Составьте программу для вывода в массиве C[1..4,1..3] сумм столбцов этого массива.

0 голосов
42 просмотров

Составьте программу для вывода в массиве C[1..4,1..3] сумм столбцов этого массива.


Информатика (19 баллов) | 42 просмотров
Дан 1 ответ
0 голосов
Правильный ответ
// PascalABC.NET 3.2, сборка 1353 от 27.11.2016
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=MatrRandom(4,3,-50,50); a.Println(5);
  Writeln(5*a.ColCount*'-');
  foreach var c in a.Cols do Write(c.Sum:5);
end.

Пример
   44   30  -45
   10   -9   -1
   37   30   11
   24  -16  -22
---------------
  115   35  -57

(150k баллов)
0

А откуда у нас взялось 50 ?