Дана строка длинной более двух символов. Написать программу, выводящую ** экран строку,...

0 голосов
129 просмотров

Дана строка длинной более двух символов. Написать программу, выводящую на экран строку, составленную из первого, третьего и последнего символов исходной строки.


Информатика (73 баллов) | 129 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Program llllll;
var A: string;
k : integer;
begin
    readln(A);
    k := length(A);
    writeln(A[1], A[3], A[k]);
end.

Что происходит в программе? Мы берем А с индексами 3, 1 а также с индексом k, где k-- длина всего слова, которую мы определяем с помощью функции length.

(1.5k баллов)