Написать программу которая random'ным образом задает число с промежутком (-99999;99999)....

0 голосов
66 просмотров

Написать программу которая random'ным образом задает число с промежутком (-99999;99999). с помощью признаков делимости узнать, делится ли число на 3


Информатика (214 баллов) | 66 просмотров
0

язык - паскаль

Дан 1 ответ
0 голосов
Правильный ответ

На каком языке требуется написать программу?

(118 баллов)
0

паскаль

0

var a:integer;
begin
randomize;
a:=random(-99999,99999);
if a mod 3=0 then writeln('число',' ',a,' ','делится',' ','на 3 ') else writeln('число',' ',a,' ','не делится',' ','на 3 ')
end.

0

Алгоритм понятен?

0

var a:integer;
begin
randomize;
a:=random(-99999,99999);
if a mod 3=0 then writeln('число ',a,' делится на 3') else writeln('число ',a,' не делится на 3')
end. (Лучше это, я тупанул с выводом)

0

спасибо)