Напишите программу(Паскаль), которая вычисляет среднюю за неделю температуру воздуха....

0 голосов
167 просмотров

Напишите программу(Паскаль), которая вычисляет среднюю за неделю температуру воздуха. Исходные данные вводятся с клавиатуры.
Пример выходных данных:
Введите температуру
Понедельник>> 12
Вторник>> 10
Среда>> 16
Четверг>> 18
Пятница>> 17
Суббота>> 16
Воскресенье>> 14

Пример выходных данных:
Средняя температура за неделю: 14.71


Информатика (63 баллов) | 167 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

За 5 баллов в следующий раз никто программу не напишет вам
var mo,tu,we,th,fr,sa,su,a: ShortInt;
var b: Real;
Begin
Write('Температура воздуха в Понедельник: ');
Readln(mo);
Write('Температура воздуха во Вторник: ');
Readln(tu);
Write('Температура воздуха в Среду: ');
Read(we);
Write('Температура воздуха в Четверг: ');
Readln(th);
Write('Температура воздуха в Пятницу: ');
Readln(fr);
Write('Температура воздуха в Субботу: ');
Readln(sa);
Write('Температура воздуха в Воскресенье: ');
Readln(su);
a:=mo+tu+we+th+fr+sa+su;
b:=a/7;
Write('Средняя температура воздуха: ',b:0:2,' градусов.');
End.

(4.2k баллов)
0

Согласен...