Помогите написать программу ** C++ для вывода ** экран в столбик все цифры переданного ей...

0 голосов
378 просмотров

Помогите написать программу на C++ для вывода на экран в столбик все цифры переданного ей числа , начиная с первой.
Пример :
Введите натуральное число :
1234
1
2
3
4


Информатика (17 баллов) | 378 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

#include
using namespace std;

int main()
{
    int a;
    int b =0;
    cout << "Введите натуральное число :", cin >> a, cout << "\n";<br>    while (a>0){
    b = b*10+(a%10);
    a = a/10;
    }
    while (b>0){
    cout << b%10 << "\n";<br>    b = b / 10;
    }
    return 0;
}

Пример:
Введите натуральное число : 8025
8
0
2
5

(194k баллов)
0

А вы не могли бы объяснить цикл ?)Хотелось бы разобраться

0

В первом цикле число переворачивается (из 8025 получается 5208), а во втором - печатаются цифры числа начиная с младших разрядов.