В паскале составить программу которая формирует массив из 16 случайных целых чисел в...

0 голосов
73 просмотров

В паскале составить программу которая формирует массив из 16 случайных целых чисел в промежутке от -12 до 10 и подсчитывает кол-во отрицательных и нулевых элементов. Распишите подробно, пожалуйста.


Информатика (133 баллов) | 73 просмотров
Дан 1 ответ
0 голосов

При копировании кода на сайт из IDE автоматически убираются пробелы. Ниже будет скриншот того, как должен будет выглядеть код.

program zn; begin  var a: array [1..16] of integer;  var i, c: integer;  c:=0;  for i:=1 to 16 do   begin  a[i]:=random(20)-12;  writeln(a[i],' ');  if a[i]=0 then c:=c+1;  if a[i]<0 then c:=c+1;  end;  writeln('Кол-во элементов раных 0 или меньше 0: ', c);  end.<hr>image

(1.5k баллов)