Написать программу которая задает массив случайным образом и ищет минимальный элемент

0 голосов
49 просмотров

Написать программу которая задает массив случайным образом и ищет минимальный элемент


Информатика (172 баллов) | 49 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Const n=10;
var a:array[1..n] of integer;
min,i:integer;
begin
Randomize;
for i:=1 to n do begin
 a[i]:=random(51);
 write(a[i],' ');
 end;
writeln;
min:=a[1]; 
for i:=2 to n do
 if a[i]writeln('min = ',min);
end.

Пример:
26 23 27 25 35 8 40 17 43 23 
min = 8

(194k баллов)