Паскаль: Напишите программу, которая меняет местами значения двух переменных в памяти.
Круто, че
Я нубас, решаю как умею, используую что знаю. Я думаю школьники будут все таки благодарны за то, что я не юзаю сложных функций, потому что учительнице они это объяснять будут долго. Я не знал, что в паскале ток можно менять
Не знаю есть ли смысл на продвинутом уровне учить паскаль. Я бы питончику отдал приоритет.
Тут просто школьники питон не одобряют
Program llllll; var a,b,c: integer; begin writeln('Введите a'); readln(a); writeln ('Введите b'); readln(b); c := a; a := b; b := c; writeln('a = ' ,a); writeln('b = ', b); end.