Составить программу, которая заполняет моссив A(n) в порядке 1 2 3 1 2 3

0 голосов
72 просмотров

Составить программу, которая заполняет моссив A(n) в порядке 1 2 3 1 2 3


Информатика (107 баллов) | 72 просмотров
Дано ответов: 2
0 голосов
Правильный ответ
// PascalABC.NET 3.2, сборка 1325 от 19.10.2016
begin
  var n:=ReadInteger('n=');
  SeqGen(n,1,x->x mod 3 +1).Println
end.

Пример
n= 15
1 2 3 1 2 3 1 2 3 1 2 3 1 2 3
(150k баллов)
0

Во первых)Тут нужен массив, а не ваши читерские процедуры;

0

Во вторых)Они этого не изучали...

0

Ему за такую программу не засчитают оценку...

0

Fastlike спасибо большое. программу засчитали

0

Не за что

0 голосов

Program massiv123; 
const n=30; 
Type massiv=array[1..n] of integer; 
var i:integer; a:massiv; 
begin 
for i:=1 to n do 
if i mod 3=0 then a[i]:=3 
             else a[i]:=1; 
for i:=1 to n do 
if a[i]=3 then a[i-1]:=2; 
write('Массив: '); 
for i:=1 to n-1 do 
write(a[i],','); 
write(a[n],';'); 
end.

Если надо изменить кол-во цифр, то изменяйте в const n=кол-во;

(348 баллов)
0

оййй до нас это не скоро дойдет

0

я соц.гум и не понимаю информатику

0

я понимаю, но это следует обьяснить составителем нашей программы