Написать программу. В программу вводится n чисел, величину n задаёт пользователь, а также...

0 голосов
32 просмотров

Написать программу. В программу вводится n чисел, величину n задаёт пользователь, а также числа вводятся подряд.
1.Найти сумму введённых чисел.
2.Количество чисел равных 0.
3.Найти максимум и минимум среди введённых чисел. Нужно на языке С. Помогите пожалуйста.


Информатика (41 баллов) | 32 просмотров
0

На паскале?

0

Можно? Или на питоне? На Си я не потяну

Дан 1 ответ
0 голосов

Крч вот на паскале, на Си не могу, сорь

program llllll;
var
A: array [-1000..1000] of integer;
n, i, b : integer;
begin
    writeln('Введите количество чисел');
    readln(n);
    b:=0;
    for i := 1 to n do
        readln(A[i]);
    for i := 0 to (n) do
        b := b+ A[i];
    write('Это сумма ');
    writeln(b); // Это сумма.
    b:=0;
    for i := 1 to (n) do
    begin
        if A[i] = 0 then
            b := b+1
    end;
    write('Это количество нулей ');
    writeln(b) ;// это количество нулей
    b:= -1001;
    for i := 1 to (n) do
    begin
        if A[i] > b then
            b := A[i]
    end;
    write('Это максимальное число ');
    writeln(b); // Это максимальное число
        b:= 1001;
    for i := 1 to (n) do
    begin
        if A[i] < b then
            b := A[i]
    end;
    write('Это минимальное число ');
    writeln(b) // Это минимальное число
end.

(1.5k баллов)