Написать программу которая считает количество цифр в числе и их сумму. паскаль. число...

0 голосов
44 просмотров

Написать программу которая считает количество цифр в числе и их сумму. паскаль. число вводится с клавиатуры


Информатика (214 баллов) | 44 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Для натуральных чисел:
var a,k,s:integer;
begin
write('a = ');
readln(a);
k:=0; s:=0;
while a>0 do
 begin
 k:=k+1;
 s:=s+a mod 10;
 a:=a div 10;
 end;
writeln('k = ',k,', s = ',s);
end.

Пример:
a = 352186
k = 6, s = 25

(194k баллов)