Ребят помогите, легкая программа.Составить программу ** Турбо Паскале: Дана строка....

0 голосов
19 просмотров

Ребят помогите, легкая программа.Составить программу на Турбо Паскале:
Дана строка. Сформировать новую строку из 2-й, 3-й, 4-й и последней букв.


Информатика (38 баллов) | 19 просмотров
0

Написал, пока ответ ждал

Дан 1 ответ
0 голосов
Правильный ответ

Var s1,s2:string;
begin
writeln('Введите строку:');
readln(s1);
s2:=s1[2]+s1[3]+s1[4]+s1[length(s1)];
writeln(s2);
end.

Пример:
Введите строку:
программа
рога

(194k баллов)
0

Спасибо, только мне без массива надо было

0

s2:=COPY(s1,2,1)+COPY(s1,3,1)+COPY(s1,4,1)+COPY(s1,length(s1),1);