Написать программу ** паскале С=корень а в квадрате + b в квадрате

0 голосов
63 просмотров

Написать программу на паскале
С=корень а в квадрате + b в квадрате


Информатика (22 баллов) | 63 просмотров
Дано ответов: 2
0 голосов

Varc,a,b : real;beginwriteln('введите длину а.');readln(a);writeln('Введите длину b.');readln(b);c:= sqrt(sqr(a)+sqr(b));if c>0 thenwriteln ('С = ',c)else writeln('Такого С не существует.');end.

(52 баллов)
0

var
c,a,b : real;
begin
writeln('введите длину а.');
readln(a);
writeln('Введите длину b.');
readln(b);
c:= sqrt(sqr(a)+sqr(b));
if c>0 then
writeln ('С = ',c)
else
writeln('Такого С не существует.');
end.

0

Отправил в комментарии,чтобы скопировал нормально по строкам(Программа рабочая,проверил в компиляторе)

0 голосов

Алгоритм ветвление, поэтому должно быть верно.


image
(932 баллов)