y:=x*x-((sqrt(57-0.3*x*x*x))/(x-4) для заданного числа x вычислить y написать программу в...

0 голосов
59 просмотров

y:=x*x-((sqrt(57-0.3*x*x*x))/(x-4) для заданного числа x вычислить y написать программу в паскаль с условиями. х-4 не равно 0 и 57-0,3*х*х*х>0


Информатика (32 баллов) | 59 просмотров
Дан 1 ответ
0 голосов

uses crt;
var x,y:real;
begin
clrscr;
writeln('x=');
read(x);
if (x<>4) and (57-0.3*x*x*x>0) then
begin
y:=x*x-((sqrt(57-0.3*x*x*x)))/(x-4);
writeln;
write('y=',y);
end
else writeln('error');
end.

(7.2k баллов)