НАПИСАТЬ ПРОГРАММУ ** PASCAL"Дана строка символов S, состоящая максимум из 250 символов....

0 голосов
36 просмотров

НАПИСАТЬ ПРОГРАММУ НА PASCAL
"Дана строка символов S, состоящая максимум из 250 символов. Напишите программу, которая проверит является ли строка S палиндромом. Примеры палиндромов: ‘COJOC’, ‘CAZAC’, ‘POTOP’, ‘ROTOR’."


Информатика (613 баллов) | 36 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var
s:string;
l,i:byte;
begin
readln(s);
l := length(s);
for i:= 1 to l div 2 do begin
if s[i] <> s[l-i+1] then begin
writeln('NO');
halt;
end;
end;
writeln('YES');
end.

(72 баллов)
0

НЕ работает!

0

конкретнее.

0

какая ошибка?

0

Program2.pas(13) : Встречено '.', а ожидалось ';'

0

Я добавил еще один end но все равно она не находит палиндромы

0

var
s:string;
l,i:byte;
begin
assign(input,'input.txt');
reset(input);
assign(output,'output.txt');
rewrite(output);
readln(s);
l := length(s);
for i:= 1 to l div 2 do begin
if s[i] <> s[l-i+1] then begin
writeln('NO');
halt;
end;
end;
writeln('YES');
close(input);
close(output);
end.

0

переписал, протестил. должно работать.

0

если работаешь в ABC Pascal, вот другой код:

0

var
s:string;
l,i:byte;
begin
readln(s);
l := length(s);
for i:= 1 to l div 2 do begin
if s[i] <> s[l-i+1] then begin
writeln('NO');
halt;
end;
end;
writeln('YES');
end.