Напишите программу подсчета количества и суммы нечетных элементов массива

0 голосов
124 просмотров

Напишите программу подсчета количества и суммы нечетных элементов массива


Информатика (15 баллов) | 124 просмотров
0

Массив двумерный или одномерный?

0

Ввод элементов вручную или рандомом?

0

вручную

0

нет рандомно

Дано ответов: 2
0 голосов
Правильный ответ

Если что нибудь нужно пояснить или изменить, пиши.
const n=10;  //вместо 10 количество ячеек в массиве (любое)
var a: array [1..n] of integer;
i,k,s: integer;
begin
randomize;
for i:=1 to n do begin
a[i]:=random(100);
  if i mod 2<>0 then
     begin k:=k+1; s:=s+a[i]; end; end; 
writeln(k,'  ',S) 
 end.

(855 баллов)
0

Если честно чуть чуть не понятно, можешь пожалуйста написать в столбик

0

Перезагрузи страницу

0

if i mod 2<>0 then мы обычно так не записываем, и через констант не решаем

0

А как вы записываете?

0

var i,k: integer;

0

for i=1 to 10 do if a {i}> 50 then k:=k+1 например вот так

0

У меня также. For находится немного выше. Могу оформить по другому. const n=10;
var a: array [1..n] of integer;
i,k,s: integer;
begin
randomize;
for i:=1 to n do a[i]:=random(100);

for i:=1 to n do
if i mod 2<>0 then
begin k:=k+1; s:=s+a[i]; end;
writeln(k,' ',S)
end.

0

спасибо))

0

Рада помочь)

0 голосов
Код Pascal1 2 3 4 5 6 7 8 9 10 11 12 begin   var Size := ReadLnInteger('Размер массива =');   var A : array of Integer; SetLength(A, Size);   for var i := 0 to pred(Size) do     A[i] := ReadLnInteger('A[' + (i+1).ToString + '] =');   WriteLn('Введён массив A = ', A);   var count := 0; for var i := 0 to pred(Size) do if Not odd(A[i]) then count += 1;   WriteLn('В массиве чётных элементов: ', count);   var max := 0; for var i := 1 to pred(Size) do if A[max] < A[i] then max := i;   var k := ReadLnInteger('k = '); A[max] *= k;   WriteLn('Массив A = ', A); end.
(96 баллов)