Нужно составить программу ветвления по информатике!Для задачи: ** приеме у педиатра...

0 голосов
54 просмотров

Нужно составить программу ветвления по информатике!Для задачи:
На приеме у педиатра производится измерение роста и всеса грудных детей в возрасте до трех месяцев.Компьютер определить рост и вес месяц назад .
Рост и вес ребенка в день приема,если ребенок на три сантиметра вырос и более,а вес увеличился на 700 грамм и более выдается сообщениие ,что развивается хорошо,если прибавил меньше трех сантиметров или вес меньше чем на 700 грамм,выдается сообщение ребенок меньше нормы


Информатика (72 баллов) | 54 просмотров
Дан 1 ответ
0 голосов

Решение на Pascal (если не подходит - скажите):

program pediatr;
var
  h_old, h_new, w_old, w_new: integer;
begin
  write('введите рост ребёнка месяц назад (в см): ');
  readln(h_old);
  write('введите рост ребёнка сейчас (в см): ');
  readln(h_new);
  write('введите вес ребёнка месяц назад (в г): ');
  readln(w_old);
  write('введите рост ребёнка сейчас (в г): ');
  readln(w_new);
  if ( (h_new - h_old) >= 3 ) and ( (w_new - w_old) >= 700) then
    writeln('Ваш ребёнок развивается хорошо')
  else
    writeln('Ваш ребёнок меньше нормы');
end.

(7.2k баллов)
0

Нет,нужно в программе Basic