Нужно написать программу ** Pascal.Программа должна посчитать среднюю оценку...

0 голосов
37 просмотров

Нужно написать программу на Pascal.Программа должна посчитать среднюю оценку ученика.Например: "Введите ваши оценки: 54454",программа должна вывести: "Ваш средний балл: 4,4".Человек может вводить сколько угодно значений


Информатика (170 баллов) | 37 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var marks:string; i,m,c,s,k:integer;
begin
write('Введите ваши оценки: ');
readln(marks);
s:=0; k:=0;
for i:=1 to length(marks) do
 if marks[i] in ['2'..'5']
  then begin val(marks[i],m,c); s:=s+m; k:=k+1 end;
writeln('Ваш средний балл: ',s/k);
end.

Пример:
Введите ваши оценки: 54454
Ваш средний балл: 4.4

(194k баллов)
0

Большое спасибо.А не можешь сказать,как вообще работает программа ?