Помогите написать программу в С++

0 голосов
26 просмотров

Помогите написать программу в С++


image

Информатика (24 баллов) | 26 просмотров
Дан 1 ответ
0 голосов

#include
#include
using std::cout;
using std::cin;
using std::endl;
int F(int N);
int main()
{
  int N;
  cin >> N;
  cout << F(N);  я не понял, по условию сказано "первого, большего введенному m" если надо найти значение следующего после введенного, то вместо F(N) надо F(N+1) мол если ты ввел 14, то тебе нужно найти значение следующего(15), как-то так.<br>  _getch();
}
int F(int N)
{
   if (N >= 2)
     return F(N - 1) + F(N - 2);
   else
     return N;
 }

(68 баллов)