Написать программу. Чтоб вводимое число делилось ** 2 пока она не станет 0. И пусть...

0 голосов
31 просмотров

Написать программу. Чтоб вводимое число делилось на 2 пока она не станет 0. И пусть ввыведит все деление)


Информатика (159 баллов) | 31 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Pascal:

var
a:integer;
begin
write('Введите число: ');
readln(a);
repeat
a:=a div 2;
writeln(a);
until a=0;
end.

(1.1k баллов)
0

спасибо)